Please start any new threads on our new site at We've got lots of great SQL Server experts to answer whatever question you can come up with.

Our new SQL Server Forums are live! Come on over! We've restricted the ability to create new threads on these forums.

SQL Server Forums
Profile | Active Topics | Members | Search | Forum FAQ
Save Password
Forgot your Password?

 All Forums
 SQL Server 2008 Forums
 High Availability (2008)
 Unable to establish mirror, Error 11001
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

1 Posts

Posted - 01/03/2013 :  15:36:34  Show Profile  Reply with Quote
My coworker and I have inherited a network with 2 machines, both running Server 2008 Enterprise SP2 and SQL Server 2008 R2. They are in different domains physically separated on a secure connection between 2 ASA’s.

1 week ago I came in to work to see their status showed (Mirror, disconnected). I attempted to restore the mirror using online help, but to no avail. I broke the mirror in an effort to recreate it. They are in different domains physically separated on a secure connection between 2 ASA’s.

They don’t have certificates for the mirror and they don’t have a witness.

When trying to create the mirror, whether we connect via FQDN or IP, we get this error:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No such host is known.) (Microsoft SQL Server, Error: 11001)

Troubleshooting efforts have included:
-we were able to ping successfully between servers using both IP addresses and FQDN’s
-we ensured 1433 and 5022 ports were listening on both servers
-we initiated successful telnet sessions from both mirror computers to the other and verified they are accepting connections
-verified correct firewall rules for both ASA’s
-turned off windows firewalls for both machines and disabled McAfee
-verified both devices have entries in their etc/hosts file
-confirmed both machines have SQLServer and SQL Server Browser services were running
-run ‘sqlcmd -L’ and didn’t return either mirror computer, but I believe this is because they are on different domains
-enabled both Named Pipes and TCP/IP in the Protocols for MSSQLSERVER, making sure TCP/IP is set to 1433
-checked to make sure SQL Server allows remote connections on both machines
-added incoming/outgoing domain firewall rules to allow traffic on 1433 and 5022 on both machines. These rules were not originally in place, but we tried it for troubleshooting.

Can anyone help with some ideas? We didn’t create this connection and aren’t SQL devs, so we are stuck.

Starting Member

35 Posts

Posted - 01/03/2013 :  20:11:15  Show Profile  Reply with Quote
I think the best way would be to try to set up the endpoints using certificates in this situation. From your description I am kind of confused how this worked. I assume there is a trust between those domains.

The right approach would be to get a profiler trace from both sides with all errors and warnings + RPC started and completed. You could than check if the issue is within sql server and if the communication at least works just find.

Keep in mind, that officially the mirror and the principal should have the same SQL Server Version and build number.

(if you need i could help you troubleshooting this write me a private message or e-mail)
Go to Top of Page

Starting Member

35 Posts

Posted - 01/03/2013 :  20:12:26  Show Profile  Reply with Quote
p.s. did you restore also the transaction log?
Go to Top of Page
  Previous Topic Topic Next Topic  
 Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.02 seconds. Powered By: Snitz Forums 2000