Please start any new threads on our new site at We've got lots of great SQL Server experts to answer whatever question you can come up with.

Our new SQL Server Forums are live! Come on over! We've restricted the ability to create new threads on these forums.

SQL Server Forums
Profile | Active Topics | Members | Search | Forum FAQ
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 SQL Server Administration (2005)
 Sql Server 2005 - error occurred during the pre-lo
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Posting Yak Master

105 Posts

Posted - 05/22/2013 :  17:48:05  Show Profile  Reply with Quote
I am having following error:
A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: Shared Memory Provider error: 0 – No Process is on the other end of the pipe.) ((Microsoft SQL Server, Error: 233)

I tried to Force Protocol Encryption, checked other Network protocol settings but didn't work.
2) I also tried Surface Area configuration for services & connections ==> Remote Connections > Selected Using both TCP/IP and Named pipes & Restart SQL Server & SQL Server Browser service.

Appreciate your help!


Edited by - poratips on 05/22/2013 17:49:27

Posting Yak Master

105 Posts

Posted - 05/23/2013 :  17:33:18  Show Profile  Reply with Quote
I have done so far following:
1) SQL Server service is up and running
Run “sqlcmd -L” ==> Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

>osql -L
==> Servers:

— NONE –

>sqlcmd -L

Servers: MTDB

2) Enabled TCP/IP in SQL Server Configuration

3) All Firewall are off

4) Enabled Remote Connection

5) Enabled SQL Server Browser Service

Go to Top of Page

Posting Yak Master

105 Posts

Posted - 05/27/2013 :  19:54:01  Show Profile  Reply with Quote
I tried many other steps but none of the works, any other ideas?
When I m trying to restart the Sql Agent but it starts and stops immediately, any help?

Go to Top of Page

The Chadinator

1974 Posts

Posted - 05/27/2013 :  20:19:04  Show Profile  Visit chadmat's Homepage  Reply with Quote
Do you see this message in your errorlog? "The certificate was successfully loaded for encryption".

Make sure there are no expired certificates in the MMC certificates snap in, if there are, delete them.


Go to Top of Page

Posting Yak Master

105 Posts

Posted - 05/28/2013 :  13:21:50  Show Profile  Reply with Quote
It was security certificate issue, so it was fixed after renaming.

Thank for your help!

Go to Top of Page
  Previous Topic Topic Next Topic  
 Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.03 seconds. Powered By: Snitz Forums 2000